jQuery読み込みの覚え書き

GoogleのAPIを使った読み込み

<script type="text/javascript" src="http://www.google.com/jsapi"></script>
<script type="text/javascript">google.load("jquery", "1.4");</script>


(“jquery”, “1.4”)の部分はバージョン指定で
この場合、1.4.x の最新版が読み込まれる。

(“jquery”, “1”)とすれば、1.x.xの最新版になる。

SSL対応ページでは
https://www.google.com/jsapi
とすればOK.

Related Posts

2 Comments

  • 會澤賢一

    1月 th, 2011 2:58 PM

    よけいなお世話ですが、私これではまったので一言。
    使うライブラリによっては、最新版では都合が悪いものがあります。特に、1.4.2と現行1.4.4では微妙に動作が違うところがあります。UIリリースで変わったのか?
    なので、私はバージョン決めうちで今使ってます。
    もしなんかおかしいと思ったら、バージョン決めうちも考慮した方がいいかもしれないです。

  • かむ

    1月 th, 2011 7:44 PM

    會澤さん

    それはありますね。
    ただ固定でしたら、この方法自体の意味があまりない気がします。
    (コピペ一発で出来るのは楽でいいですが)
    固定でしたらソースを自サーバに置くという選択肢があります。


    jQueryをある程度最新版にしておきたいユーザに便利な方法ではないかと。

    そんなやつは、プラグインが未対応で動かなくなる前にチェックする手間をかけるような
    業務的な人間かもですが(^_^;)